Minor grammar fixes
[openafs-wiki.git] / InstallOpenAFSClient.mdwn
index 4d94a9b..8d075cd 100644 (file)
@@ -40,7 +40,7 @@ Install those RPMS. If you don't know how to do this, then this document isn't i
 
 Follow the instructions that were output during the RPM install. In particular, edit /usr/vice/etc/ThisCell.
 
-If you you will need to [[KerberosV]] on your system. If you have not done so, do so now. Instructions for doing that are outside of the scope of this document.
+You will need to install [[KerberosV]] on your system. If you have not done so, do so now. Instructions for doing that are outside of the scope of this document.
 
 ##### <a name="Start AFS"></a> Start AFS
 
@@ -48,12 +48,77 @@ Start the AFS client, by running '/etc/rc.d/init.d/afs start'
 
 Verify that /afs/&lt;your-cell-here&gt; is readable.
 
-Get AFS tokens with klog, or translate existing kerberos tickets with aklog, and verify that you can modify files in AFS.
+Get AFS tokens with aklog, or translate existing kerberos tickets with aklog, and verify that you can modify files in AFS.
 
 Once you've verified that AFS works correctly, you may want to configure AFS to start automatically, via whatever mechanism you prefer.
 
 -- David Nolan - 29 Jul 2003
 
+#### <a name="Raspberri Pi">Raspberry Pi</a>
+
+You will need at least a 4GB card to download all the necessary software and linux kernel
+
+Much of this is taken from <http://www.raspberrypi.org/phpBB3/viewtopic.php?f=71&t=17666>
+
+Other guides:
+rpi-update at <https://github.com/Hexxeh/rpi-update/>
+
+To get started:
+Install the latest dist and necessary tools
+
+    sudo bash
+    apt-get update
+    apt-get -y dist-upgrade
+    apt-get -y install gcc make git build-essential dkms
+
+Install rpi-update and grab the latest firmware
+
+    cd rpi-update
+    apt-get install ca-certificates
+    sudo wget http://goo.gl/1BOfJ -O /usr/bin/rpi-update && sudo chmod +x /usr/bin/rpi-update
+
+Grab latest kernel
+
+    cd /usr/src
+    wget  https://github.com/raspberrypi/linux/tarball/rpi-3.2.27 -O rpi-3.2.27.tgz
+    tar xzf rpi-3.2.27.tgz
+
+Grab the configs from the kernel
+
+    cd raspberrypi-linux-*
+    zcat /proc/config.gz > .config
+    make oldconfig
+    make modules_prepare
+
+Get the module symbol version 
+
+    wget https://github.com/raspberrypi/firmware/raw/master/extra/Module.symvers
+Make symlinks for the build system
+
+    KSRC=`pwd`
+    pushd /lib/modules/`uname -r`
+    ln -s ${KSRC} source
+    ln -s ${KSRC} build
+    popd
+    pushd /usr/src
+    ln -s ${KSRC} linux-`uname -r`
+    ln -s ${KSRC} linux
+    popd
+
+Install kerberos packages
+
+    apt-get install krb5-auth-dialog krb5-user krb5-clients libpam-ccreds libpam-krb5
+
+Install the afs client and related modules
+
+    apt-get install  openafs-modules-dkms openafs-{client,krb5}
+
+if it doesn't go successfuly, you can re-run it with:
+
+    dpkg-reconfigure openafs-modules-dkms
+
+-- Joe Foley 22 Feb 2013 (Created from RU website)
+
 #### <a name="Mac OS X 10.3"></a> Mac OS X 10.3
 
 Some good guides into getting [[OpenAFS]] installed on Mac OS X 10.3 can be found at :
@@ -63,3 +128,4 @@ Some good guides into getting [[OpenAFS]] installed on Mac OS X 10.3 can be foun
 [http://www.ibiblio.org/macsupport/kerberos/kerberos10\_2.html](http://www.ibiblio.org/macsupport/kerberos/kerberos10_2.html)
 
 -- Clark Hale - 20 Jan 2005 Removed Crap, and dead link.
+-- Caitlyn Marko - 24 Aug 2017 Removed broken link.