Remove support for Solaris pre-8
[openafs.git] / src / platform / SOLARIS / fs_conv_sol26.c
index cf24ab9..3bf52e8 100644 (file)
@@ -13,7 +13,6 @@
 
 #include <stdio.h>
 
-#if defined(AFS_SUN54_ENV)
 #define OSVERS "SunOS 5.6"
 #include <sys/types.h>
 #include <rx/xdr.h>
@@ -332,11 +331,7 @@ ProcessAfsInodes(devname, partition)
                int p5;
                quad *q;
 
-#if    defined(AFS_SUN56_ENV)
                q = (quad *) & (p->di_ic.ic_lsize);
-#else
-               q = &(p->di_ic.ic_size);
-#endif
 
                p1 = p->di_gen;
                p2 = p->di_ic.ic_flags;
@@ -706,17 +701,3 @@ CheckMountedDevice(devName)
        return 1;
     return 0;
 }
-
-#else /* !AFS_SUN54_ENV */
-
-#include "AFS_component_version_number.c"
-
-main(argc, argv)
-     int argc;
-     char *argv[];
-{
-    printf
-       ("%s: **ONLY** supported for Solaris 2.4 and later ...\n",
-        argv[0]);
-}
-#endif /* !AFS_SUN5_ENV */