rx: Raise minimum Linux atomics version to 2.6
authorAndrew Deason <adeason@sinenomine.net>
Wed, 25 Jul 2012 15:45:16 +0000 (10:45 -0500)
committerDerrick Brashear <shadow@dementix.org>
Wed, 25 Jul 2012 20:25:12 +0000 (13:25 -0700)
commit410a55addfcd055ac666f9bc5450b238648d07bf
tree6859fd90b4ebec24493c09a6755d65cdb66e2a49
parent6dd0bc6bed79013fe1737f3e9016066ee74958fd
rx: Raise minimum Linux atomics version to 2.6

Linux 2.4 does not have atomic_dec_return. If we switch to a
dec_and_test-like API, then we could use the Linux 2.4 atomics. But
for now, just raise the minimum to 2.6, and for 2.4 and below just use
the generic atomics implementation so we can build.

Change-Id: Ie584bd420839dbcbe3158fe7b50df633cb7eba6d
Reviewed-on: http://gerrit.openafs.org/7875
Tested-by: BuildBot <buildbot@rampaginggeek.com>
Reviewed-by: Derrick Brashear <shadow@dementix.org>
src/rx/rx_atomic.h