doc: Document dependencies required for building everything
authorGarrett Wollman <wollman@csail.mit.edu>
Fri, 14 Feb 2014 04:03:59 +0000 (23:03 -0500)
committerJeffrey Altman <jaltman@your-file-system.com>
Fri, 14 Feb 2014 20:58:40 +0000 (12:58 -0800)
commit7a7ee20bb609ec0b23d36d2376ffc6eda58fa47b
tree08a8d0c136d561536c3227c3661897a4252c8b9d
parentb7326e487f6387033282cc5d1128b00a0456673a
doc: Document dependencies required for building everything

Add a new section to README.DEVEL that describes the packages required
to build everything (including all optional code like the FUSE-based
user-mode client).  Start with what I figured out for FreeBSD (tested
on a clean 10.0 install) and what Russ Allbery described on the
openafs-devel list in
<https://lists.openafs.org/pipermail/openafs-devel/2014-February/019759.html>.

Change-Id: Ib90cd653a822f8699df613aabdd3442edc10c98a
Reviewed-on: http://gerrit.openafs.org/10844
Reviewed-by: Ken Dreyer <ktdreyer@ktdreyer.com>
Reviewed-by: Jeffrey Altman <jaltman@your-file-system.com>
Tested-by: Jeffrey Altman <jaltman@your-file-system.com>
README.DEVEL