From d0a2889098526aa148d99e042aa8c3f7855565f7 Mon Sep 17 00:00:00 2001 From: Mark Vitale Date: Wed, 6 Feb 2019 16:55:03 -0500 Subject: [PATCH] auth: remove stale "magic number" comment A comment in GenericAuth() refers to a "magic number" which used to be present as: *aindex = 2; Commit d5622d03196762bd8a60404fea98b4bb044e076d made this a proper enum: *aindex = RX_SECIDX_KAD; Update the comment to remove mention of a "magic number". No functional change is incurred by this commit. Change-Id: I1d4770211fe4f88822426a9fe19db77bbb0d7738 Reviewed-on: https://gerrit.openafs.org/13490 Tested-by: BuildBot Reviewed-by: Cheyenne Wills Reviewed-by: Benjamin Kaduk --- src/auth/authcon.c | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/src/auth/authcon.c b/src/auth/authcon.c index 21ef54f..aa29f79 100644 --- a/src/auth/authcon.c +++ b/src/auth/authcon.c @@ -164,10 +164,7 @@ GenericAuth(struct afsconf_dir *adir, return QuickAuth(astr, aindex); } - /* Next, we have ticket, kvno and session key, authenticate the connection. - * We use a magic # instead of a constant because of basic compilation - * order when compiling the system from scratch (rx/rxkad.h isn't installed - * yet). */ + /* Next, we have ticket, kvno and session key, authenticate the connection.*/ tclass = (struct rx_securityClass *) rxkad_NewClientSecurityObject(enclevel, &session, kvno, ticketLen, tbuffer); -- 1.9.4