style tweaks
[openafs-wiki.git] / AFSLore / SMBtoAFS / samba-2.2.7_afstoken.spec
1 %define initdir %{_sysconfdir}/rc.d/init.d
2 %define auth %(test -f /etc/pam.d/system-auth && echo /etc/pam.d/system-auth || echo)
3
4 Summary: The Samba SMB server.
5 Name: samba
6 Version: 2.2.7
7 Release: 2_afstoken
8 License: GNU GPL Version 2
9 Group: System Environment/Daemons
10 URL: http://www.samba.org/
11
12 Source: ftp://us2.samba.org/pub/samba/%{name}-%{version}.tar.bz2
13
14 # Red Hat specific replacement-files
15 Source1: samba.log
16 Source2: samba.xinetd
17 Source3: swat.desktop
18 Source4: samba.sysconfig
19 Source5: smb.init
20 Source6: samba.pamd
21 Source7: smbprint
22 Source8: winbind.init
23
24 # Don't depend on Net::LDAP
25 Source999: filter-requires-samba.sh
26
27 # generic patches
28 Patch0: samba-2.2.4-smb.conf.patch
29 Patch1: samba-2.2.0-smbw.patch
30 Patch3: samba-2.0.5a-gawk.patch
31 Patch5: samba-2.0.7-krb5-1.2.patch
32 Patch6: samba-2.0.7-buildroot.patch
33 Patch7: samba-2.2.3a-smbpass.patch
34 Patch11: samba-2.2.0-logname.patch
35 Patch13: samba-2.2.2-winsfixes.patch
36 Patch14: samba-2.2.3-smbadduserloc.patch
37 Patch15: samba-2.2.7-lfsclient.patch
38 # Not used, but it have some patches which might be needed later...
39 Patch16: samba-2.2.2-smbadduser.patch
40 Patch17: samba-2.2.7-afstoken.patch
41
42 Requires: pam >= 0.64 %{auth} samba-common = %{version} 
43 Requires: logrotate >= 3.4 initscripts >= 5.54-1 
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
46 Prereq: fileutils sed /etc/init.d 
47 BuildRequires: pam-devel, readline-devel, ncurses-devel, fileutils, libacl-devel
48
49
50 # Working around perl dependency problem from docs
51 %define __find_requires %{SOURCE999}
52
53 %description
54 Samba is the protocol by which a lot of PC-related machines share
55 files, printers, and other information (such as lists of available
56 files and printers). The Windows NT, OS/2, and Linux operating systems
57 support this natively, and add-on packages can enable the same thing
58 for DOS, Windows, VMS, UNIX of all kinds, MVS, and more. This package
59 provides an SMB server that can be used to provide network services to
60 SMB (sometimes called "Lan Manager") clients. Samba uses NetBIOS over
61 TCP/IP (NetBT) protocols and does NOT need the NetBEUI (Microsoft Raw
62 NetBIOS frame) protocol.
63
64 %package client
65 Summary: Samba (SMB) client programs.
66 Group: Applications/System
67 Requires: samba-common = %{version}
68 Obsoletes: smbfs
69
70 %description client
71 The samba-client package provides some SMB clients to compliment the
72 built-in SMB filesystem in Linux. These clients allow access of SMB
73 shares and printing to SMB printers.
74
75 %package common
76 Summary: Files used by both Samba servers and clients.
77 Group: Applications/System
78
79 %description common
80 Samba-common provides files necessary for both the server and client
81 packages of Samba.
82
83 %package swat
84 Summary: The Samba SMB server configuration program.
85 Group: Applications/System
86 Requires: samba = %{version} xinetd
87
88 %description swat
89 The samba-swat package includes the new SWAT (Samba Web Administration
90 Tool), for remotely managing Samba's smb.conf file using your favorite
91 Web browser.
92
93 %prep
94 %setup -q
95
96 # copy Red Hat specific scripts
97 cp %{SOURCE5} packaging/RedHat/
98 cp %{SOURCE6} packaging/RedHat/
99 cp %{SOURCE7} packaging/RedHat/
100 cp %{SOURCE8} packaging/RedHat/winbind.init
101
102 %patch0 -p1 -b .oldconf
103 %patch1 -p1 -b .smbw
104 %patch3 -p1 -b .gawk
105 %patch5 -p1 -b .krb5-1.2
106 %patch6 -p1 -b .buildroot
107 %patch7 -p1 -b .smbpass
108 %patch13 -p1 -b .winsfixes
109 %patch14 -p1 -b .locfix
110 %patch15 -p1 -b .lfs
111 %patch17 -p1 -b .afstoken
112
113 %build
114
115 cd source
116 %ifarch i386 sparc
117 RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64"
118 %endif
119
120 #bug in 2.2.4
121 perl -pi -e "s|-symbolic||" Makefile.in
122
123 %configure \
124         --libdir=%{_sysconfdir}/samba \
125         --with-fhs \
126         --with-privatedir=%{_sysconfdir}/samba \
127         --with-lockdir=/var/cache/samba \
128         --with-swatdir=%{_datadir}/swat \
129         --with-codepagedir=%{_datadir}/samba/codepages \
130         --without-automount \
131         --without-smbmount \
132         --without-pam \
133         --without-mmap \
134         --without-quotas \
135         --without-smbwrapper \
136         --without-libsmbclient \
137         --without-utmp \
138         --with-piddir=/var/run/samba \
139         --without-acl-support \
140         --with-afs \
141         --with-ssl \
142         --without-vfs
143 #       --without-pam_smbpass \
144
145
146 make  CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" \
147         all smbfilter nsswitch/libnss_wins.so debug2html
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 mkdir -p $RPM_BUILD_ROOT/sbin
153 mkdir -p $RPM_BUILD_ROOT/usr/{sbin,bin}
154 mkdir -p $RPM_BUILD_ROOT/%{initdir}
155 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/{pam.d,logrotate.d}
156 mkdir -p $RPM_BUILD_ROOT/var/{log,spool}/samba
157 mkdir -p $RPM_BUILD_ROOT/var/cache/samba
158 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/swat/using_samba
159 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/samba/codepages 
160
161 cd source
162
163 %makeinstall \
164         BINDIR=$RPM_BUILD_ROOT%{_bindir} \
165         BASEDIR=$RPM_BUILD_ROOT%{_prefix} \
166         SBINDIR=$RPM_BUILD_ROOT%{_sbindir} \
167         DATADIR=$RPM_BUILD_ROOT%{_datadir} \
168         LOCKDIR=$RPM_BUILD_ROOT/var/cache/samba \
169         PRIVATEDIR=$RPM_BUILD_ROOT%{_sysconfdir}/samba \
170         LIBDIR=$RPM_BUILD_ROOT%{_sysconfdir}/samba \
171         CONFIGDIR=$RPM_BUILD_ROOT%{_sysconfdir}/samba \
172         VARDIR=$RPM_BUILD_ROOT/var/log/samba \
173         CODEPAGEDIR=$RPM_BUILD_ROOT%{_datadir}/samba/codepages \
174         SWATDIR=$RPM_BUILD_ROOT%{_datadir}/swat \
175         SAMBABOOK=$RPM_BUILD_ROOT%{_datadir}/swat/using_samba \
176         PIDDIR=$RPM_BUILD_ROOT/var/run/samba
177
178 cd ..
179
180 # Install other stuff
181 install -m644 packaging/RedHat/smb.conf $RPM_BUILD_ROOT%{_sysconfdir}/samba/smb.conf
182 install -m755 source/script/mksmbpasswd.sh $RPM_BUILD_ROOT%{_bindir}
183 install -m644 packaging/RedHat/smbusers $RPM_BUILD_ROOT/etc/samba/smbusers
184 install -m755 packaging/RedHat/smbprint $RPM_BUILD_ROOT%{_bindir}
185 install -m755 source/script/smbadduser $RPM_BUILD_ROOT%{_bindir}
186 install -m755 packaging/RedHat/smb.init $RPM_BUILD_ROOT%{initdir}/smb
187 install -m755 packaging/RedHat/winbind.init $RPM_BUILD_ROOT%{initdir}/winbind
188 ln -s ../..%{initdir}/smb  $RPM_BUILD_ROOT%{_sbindir}/samba
189 install -m644 packaging/RedHat/samba.pamd.stack $RPM_BUILD_ROOT/etc/pam.d/samba
190 install -m644 $RPM_SOURCE_DIR/samba.log $RPM_BUILD_ROOT/etc/logrotate.d/samba
191 echo 127.0.0.1 localhost > $RPM_BUILD_ROOT%{_sysconfdir}/samba/lmhosts
192
193 # pam_smbpass
194 mkdir -p $RPM_BUILD_ROOT/lib/security
195 #mv $RPM_BUILD_ROOT%{_bindir}/pam_smbpass.so $RPM_BUILD_ROOT/lib/security/pam_smbpass.so
196 #cp -r source/pam_smbpass/ docs/
197 rm -f docs/pam_smbpass/*.*
198
199 # winbind
200 mkdir -p $RPM_BUILD_ROOT/lib
201 install -m 755 source/nsswitch/libnss_winbind.so $RPM_BUILD_ROOT/lib/libnss_winbind.so
202 install -m 755 source/nsswitch/libnss_wins.so $RPM_BUILD_ROOT/lib/libnss_wins.so
203 ln -s libnss_wins.so  $RPM_BUILD_ROOT/lib/libnss_wins.so.2
204 ln -s libnss_winbind.so  $RPM_BUILD_ROOT/lib/libnss_winbind.so.2
205
206 # VFS - recycling
207
208 # libsmbclient
209
210 mkdir -p $RPM_BUILD_ROOT/usr/{lib,include}
211
212
213 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xinetd.d
214 install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/xinetd.d/swat
215
216 mkdir -p $RPM_BUILD_ROOT/usr/share/applications/
217 install -m644 %{SOURCE3} $RPM_BUILD_ROOT/usr/share/applications/samba-swat.desktop
218
219 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
220 install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/samba
221
222 # remove this or it ends up in %doc
223 rm -rf docs/htmldocs/using_samba
224 rm -rf docs/faq/*sgml
225
226 # remove html'ized man pages:
227 rm -rf docs/htmldocs/*.[0-9].*
228
229 %clean
230 rm -rf $RPM_BUILD_ROOT
231
232 %post
233 /sbin/chkconfig --add smb
234
235
236 %preun
237 if [ $1 = 0 ] ; then
238     /sbin/chkconfig --del smb
239     /sbin/chkconfig --del winbind
240     rm -rf /var/log/samba/* /var/cache/samba/*
241     /sbin/service smb stop >/dev/null 2>&1
242 fi
243 exit 0
244
245 %postun
246 if [ "$1" -ge "1" ]; then
247         %{initdir}/smb condrestart >/dev/null 2>&1
248 fi      
249
250 %post common
251 /sbin/chkconfig --add winbind
252
253 %preun common
254 if [ $1 = 0 ] ; then
255     /sbin/chkconfig --del winbind
256     /sbin/service winbind stop >/dev/null 2>&1
257 fi
258 exit 0
259
260 %triggerpostun -- samba < 1.9.18p7
261 if [ $1 != 0 ]; then
262     /sbin/chkconfig --add smb
263 fi
264
265 %triggerpostun -- samba < 2.0.5a-3
266 if [ $1 != 0 ]; then
267     [ ! -d /var/lock/samba ] && mkdir -m 0755 /var/lock/samba
268     [ ! -d /var/spool/samba ] && mkdir -m 1777 /var/spool/samba
269     chmod 644 /etc/services
270     [ -f /etc/inetd.conf ] && chmod 644 /etc/inetd.conf
271 fi
272
273 %files
274 %defattr(-,root,root)
275 %doc README COPYING Manifest 
276 %doc WHATSNEW.txt Roadmap
277 %doc docs
278 %doc examples/autofs examples/LDAP examples/libsmbclient examples/misc examples/printer-accounting
279 %doc examples/printing
280
281 #attr(755,root,root) /lib/security/pam_smbpass.so
282 %{_sbindir}/smbd
283 %{_sbindir}/nmbd
284 %{_bindir}/make_unicodemap
285 %{_bindir}/mksmbpasswd.sh
286 %{_bindir}/smbcontrol
287 %{_bindir}/smbstatus
288 %{_bindir}/smbadduser
289 %{_bindir}/tdbbackup
290 %config(noreplace) %{_sysconfdir}/sysconfig/samba
291 %config(noreplace) %{_sysconfdir}/samba/smbusers
292 %attr(755,root,root) %config %{initdir}/smb
293 %config(noreplace) %{_sysconfdir}/logrotate.d/samba
294 %config(noreplace) %{_sysconfdir}/pam.d/samba
295
296 %dir /var/cache/samba
297 %dir /var/run/samba
298 %attr(0700,root,root) %dir /var/log/samba
299 %attr(1777,root,root) %dir /var/spool/samba
300
301 %files swat
302 %defattr(-,root,root)
303 /usr/share/applications/*
304 %config(noreplace) %{_sysconfdir}/xinetd.d/swat
305 %{_datadir}/swat
306 %{_sbindir}/swat
307
308 %files client
309 %defattr(-,root,root)
310 %{_bindir}/rpcclient
311 %{_bindir}/smbcacls
312 %{_bindir}/nmblookup
313 %{_bindir}/smbclient
314 %{_bindir}/smbprint
315 %{_bindir}/smbspool
316 %{_bindir}/smbtar
317
318 %files common
319 %defattr(-,root,root)
320 /lib/libnss_wins.so
321 /lib/libnss_wins.so.2
322 /lib/libnss_winbind.so
323 /lib/libnss_winbind.so.2
324 %{_bindir}/make_smbcodepage
325 %{_bindir}/testparm
326 %{_bindir}/testprns
327 %{_bindir}/smbpasswd
328 %{_bindir}/make_printerdef
329 %{_bindir}/wbinfo
330
331 %{_sbindir}/winbindd
332 %config(noreplace) %{_sysconfdir}/samba/smb.conf
333 %config(noreplace) %{_sysconfdir}/samba/lmhosts
334 %dir %{_datadir}/samba
335 %dir %{_datadir}/samba/codepages
336 %dir %{_sysconfdir}/samba
337 %{initdir}/winbind
338 %{_datadir}/samba/codepages/*
339
340 %changelog
341 * Wed Nov 20 2002 Bill Nottingham <notting@redhat.com> 2.2.7-2
342 - update to 2.2.7
343 - add patch for LFS in smbclient (<tcallawa@redhat.com>)
344
345 * Wed Aug 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.5-10
346 - logrotate fixes (#65007)
347
348 * Mon Aug 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.5-9
349 - /usr/lib was used in place of %%{_libdir} in three locations (#72554)
350
351 * Mon Aug  5 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.5-8
352 - Initscript fix (#70720)
353
354 * Fri Jul 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.5-7
355 - Enable VFS support and compile the "recycling" module (#69796)
356 - more selective includes of the examples dir 
357
358 * Tue Jul 23 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.5-6
359 - Fix the lpq parser for better handling of LPRng systems (#69352)
360
361 * Tue Jul 23 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.5-5
362 - desktop file fixes (#69505)
363
364 * Wed Jun 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.5-4
365 - Enable ACLs
366
367 * Tue Jun 25 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.5-3
368 - Make it not depend on Net::LDAP - those are doc files and examples
369
370 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
371 - automated rebuild
372
373 * Thu Jun 20 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.5-1
374 - 2.2.5
375
376 * Fri Jun 14 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.4-5
377 - Move the post/preun of winbind into the -common subpackage, 
378   where the script is (#66128)
379
380 * Tue Jun  4 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.4-4
381 - Fix pidfile locations so it runs properly again (2.2.4 
382   added a new directtive - #65007)
383
384 * Thu May 23 2002 Tim Powers <timp@redhat.com>
385 - automated rebuild
386
387 * Tue May 14 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.4-2
388 - Fix #64804
389
390 * Thu May  9 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.4-1
391 - 2.2.4
392 - Removed some zero-length and CVS internal files
393 - Make it build
394
395 * Wed Apr 10 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.3a-6
396 - Don't use /etc/samba.d in smbadduser, it should be /etc/samba
397
398 * Thu Apr  4 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.3a-5
399 - Add libsmbclient.a w/headerfile for KDE (#62202)
400
401 * Tue Mar 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.3a-4
402 - Make the logrotate script look the correct place for the pid files 
403
404 * Thu Mar 14 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2.3a-3
405 - include interfaces.o in pam_smbpass.so, which needs symbols from interfaces.o
406   (patch posted to samba-list by Ilia Chipitsine)
407
408 * Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.3a-2
409 - Rebuild
410
411 * Thu Feb  7 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.3a-1
412 - 2.2.3a
413
414 * Mon Feb  4 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.2.3-1
415 - 2.2.3
416
417 * Thu Nov 29 2001 Trond Eivind Glomsrød <teg@redhat.com> 2.2.2-8
418 - New pam configuration file for samba
419
420 * Tue Nov 27 2001 Trond Eivind Glomsrød <teg@redhat.com> 2.2.2-7
421 - Enable PAM session controll and password sync
422
423 * Tue Nov 13 2001 Trond Eivind Glomsrød <teg@redhat.com> 2.2.2-6
424 - Move winbind files to samba-common. Add separate initscript for
425   winbind 
426 - Fixes for winbind - protect global variables with mutex, use
427   more secure getenv
428
429 * Thu Nov  8 2001 Trond Eivind Glomsrød <teg@redhat.com> 2.2.2-5
430 - Teach smbadduser about "getent passwd" 
431 - Fix more pid-file references
432 - Add (conditional) winbindd startup to the initscript, configured in
433   /etc/sysconfig/samba
434
435 * Wed Nov  7 2001 Trond Eivind Glomsrød <teg@redhat.com> 2.2.2-4
436 - Fix pid-file reference in logrotate script
437 - include pam and nss modules for winbind
438
439 * Mon Nov  5 2001 Trond Eivind Glomsrød <teg@redhat.com> 2.2.2-3
440 - Add "--with-utmp" to configure options (#55372)
441 - Include winbind, pam_smbpass.so, rpcclient and smbcacls
442 - start using /var/cache/samba, we need to keep state and there is
443   more than just locks involved
444
445 * Sat Nov 03 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.2.2-2
446 - add "reload" to the usage string in the startup script
447
448 * Mon Oct 15 2001 Trond Eivind Glomsrød <teg@redhat.com> 2.2.2-1
449 - 2.2.2
450
451 * Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 2.2.1a-5
452 - Add patch from Jeremy Allison to fix IA64 alignment problems (#51497)
453
454 * Mon Aug 13 2001 Trond Eivind Glomsrød <teg@redhat.com>
455 - Don't include smbpasswd in samba, it's in samba-common (#51598)
456 - Add a disabled "obey pam restrictions" statement - it's not
457   active, as we use encrypted passwords, but if the admin turns
458   encrypted passwords off the choice is available. (#31351)
459
460 * Wed Aug  8 2001 Trond Eivind Glomsrød <teg@redhat.com>
461 - Use /var/cache/samba instead of /var/lock/samba 
462 - Remove "domain controller" keyword from smb.conf, it's 
463   deprecated (from #13704)
464 - Sync some examples with smb.conf.default
465 - Fix password synchronization (#16987)
466
467 * Fri Jul 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
468 - Tweaks of BuildRequires (#49581)
469
470 * Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
471 - 2.2.1a bugfix release
472
473 * Tue Jul 10 2001 Trond Eivind Glomsrød <teg@redhat.com>
474 - 2.2.1, which should work better for XP
475
476 * Sat Jun 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
477 - 2.2.0a security fix
478 - Mark lograte and pam configuration files as noreplace
479
480 * Fri Jun 22 2001 Trond Eivind Glomsrød <teg@redhat.com>
481 - Add the /etc/samba directory to samba-common
482
483 * Thu Jun 21 2001 Trond Eivind Glomsrød <teg@redhat.com>
484 - Add improvements to the smb.conf as suggested in #16931
485
486 * Tue Jun 19 2001 Trond Eivind Glomsrød <teg@redhat.com>
487   (these changes are from the non-head version)
488 - Don't include /usr/sbin/samba, it's the same as the initscript
489 - unset TMPDIR, as samba can't write into a TMPDIR owned 
490   by root (#41193)
491 - Add pidfile: lines for smbd and nmbd and a config: line
492   in the initscript  (#15343)
493 - don't use make -j
494 - explicitly include /usr/share/samba, not just the files in it
495
496 * Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
497 - mount.smb/mount.smbfs go in /sbin, *not* %%{_sbindir}
498
499 * Fri Jun  8 2001 Preston Brown <pbrown@redhat.com>
500 - enable encypted passwords by default
501
502 * Thu Jun  7 2001 Helge Deller <hdeller@redhat.de> 
503 - build as 2.2.0-1 release
504 - skip the documentation-directories docbook, manpages and yodldocs
505 - don't include *.sgml documentation in package
506 - moved codepage-directory to /usr/share/samba/codepages
507 - make it compile with glibc-2.2.3-10 and kernel-headers-2.4.2-2   
508
509 * Mon May 21 2001 Helge Deller <hdeller@redhat.de> 
510 - updated to samba 2.2.0
511 - moved codepages to %{_datadir}/samba/codepages
512 - use all available CPUs for building rpm packages
513 - use %{_xxx} defines at most places in spec-file
514 - "License:" replaces "Copyright:"
515 - dropped excludearch sparc
516 - de-activated japanese patches 100 and 200 for now 
517   (they need to be fixed and tested wth 2.2.0)
518 - separated swat.desktop file from spec-file and added
519   german translations
520 - moved /etc/sysconfig/samba to a separate source-file
521 - use htmlview instead of direct call to netscape in 
522   swat.desktop-file
523
524 * Mon May  7 2001 Bill Nottingham <notting@redhat.com>
525 - device-remove security fix again (<tridge@samba.org>)
526
527 * Fri Apr 20 2001 Bill Nottingham <notting@redhat.com>
528 - fix tempfile security problems, officially (<tridge@samba.org>)
529 - update to 2.0.8
530
531 * Sun Apr  8 2001 Bill Nottingham <notting@redhat.com>
532 - turn of SSL, kerberos
533
534 * Thu Apr  5 2001 Bill Nottingham <notting@redhat.com>
535 - fix tempfile security problems (patch from <Marcus.Meissner@caldera.de>)
536
537 * Thu Mar 29 2001 Bill Nottingham <notting@redhat.com>
538 - fix quota support, and quotas with the 2.4 kernel (#31362, #33915)
539
540 * Mon Mar 26 2001 Nalin Dahyabhai <nalin@redhat.com>
541 - tweak the PAM code some more to try to do a setcred() after initgroups()
542 - pull in all of the optflags on i386 and sparc
543 - don't explicitly enable Kerberos support -- it's only used for password
544   checking, and if PAM is enabled it's a no-op anyway
545
546 * Mon Mar  5 2001 Tim Waugh <twaugh@redhat.com>
547 - exit successfully from preun script (bug #30644).
548
549 * Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
550 - rebuild in new environment
551
552 * Wed Feb 14 2001 Bill Nottingham <notting@redhat.com>
553 - updated japanese stuff (#27683)
554
555 * Fri Feb  9 2001 Bill Nottingham <notting@redhat.com>
556 - fix trigger (#26859)
557
558 * Wed Feb  7 2001 Bill Nottingham <notting@redhat.com>
559 - add i18n support, japanese patch (#26253)
560
561 * Wed Feb  7 2001 Trond Eivind Glomsrød <teg@redhat.com>
562 - i18n improvements in initscript (#26537)
563
564 * Wed Jan 31 2001 Bill Nottingham <notting@redhat.com>
565 - put smbpasswd in samba-common (#25429)
566
567 * Wed Jan 24 2001 Bill Nottingham <notting@redhat.com>
568 - new i18n stuff
569
570 * Sun Jan 21 2001 Bill Nottingham <notting@redhat.com>
571 - rebuild
572
573 * Thu Jan 18 2001 Bill Nottingham <notting@redhat.com>
574 - i18n-ize initscript
575 - add a sysconfig file for daemon options (#23550)
576 - clarify smbpasswd man page (#23370)
577 - build with LFS support (#22388)
578 - avoid extraneous pam error messages (#10666)
579 - add Urban Widmark's bug fixes for smbmount (#19623)
580 - fix setgid directory modes (#11911)
581 - split swat into subpackage (#19706)
582
583 * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
584 - set a default CA certificate path in smb.conf (#19010)
585 - require openssl >= 0.9.5a-20 to make sure we have a ca-bundle.crt file
586
587 * Mon Oct 16 2000 Bill Nottingham <notting@redhat.com>
588 - fix swat only_from line (#18726, others)
589 - fix attempt to write outside buildroot on install (#17943)
590
591 * Mon Aug 14 2000 Bill Nottingham <notting@redhat.com>
592 - add smbspool back in (#15827)
593 - fix absolute symlinks (#16125)
594
595 * Sun Aug 6 2000 Philipp Knirsch <pknirsch@redhat.com>
596 - bugfix for smbadduser script (#15148)
597
598 * Mon Jul 31 2000 Matt Wilson <msw@redhat.com>
599 - patch configure.ing (patch11) to disable cups test
600 - turn off swat by default
601
602 * Fri Jul 28 2000 Bill Nottingham <notting@redhat.com>
603 - fix condrestart stuff
604
605 * Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
606 - add copytruncate to logrotate file (#14360)
607 - fix init script (#13708)
608
609 * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
610 - move initscript back
611 - remove 'Using Samba' book from %%doc 
612 - move stuff to /etc/samba (#13708)
613 - default configuration tweaks (#13704)
614 - some logrotate tweaks
615
616 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
617 - automatic rebuild
618
619 * Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
620 - fix logrotate script (#13698)
621
622 * Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
623 - fix initscripts req (prereq /etc/init.d)
624
625 * Wed Jul 5 2000 Than Ngo <than@redhat.de>
626 - add initdir macro to handle the initscript directory
627 - add a new macro to handle /etc/pam.d/system-auth
628
629 * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
630 - enable Kerberos 5 and SSL support
631 - patch for duplicate profile.h headers
632
633 * Thu Jun 29 2000 Bill Nottingham <notting@redhat.com>
634 - fix init script
635
636 * Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
637 - rename samba logs (#11606)
638
639 * Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
640 - initscript munging
641
642 * Fri Jun 16 2000 Bill Nottingham <notting@redhat.com>
643 - configure the swat stuff usefully
644 - re-integrate some specfile tweaks that got lost somewhere
645
646 * Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
647 - rebuild to get rid of cups dependency
648
649 * Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
650 - tweak logrotate configurations to use the PID file in /var/lock/samba
651
652 * Sun Jun 11 2000 Bill Nottingham <notting@redhat.com>
653 - rebuild in new environment
654
655 * Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
656 - change PAM setup to use system-auth
657
658 * Mon May  8 2000 Bill Nottingham <notting@redhat.com>
659 - fixes for ia64
660
661 * Sat May  6 2000 Bill Nottingham <notting@redhat.com>
662 - switch to %%configure
663
664 * Wed Apr 26 2000 Nils Philippsen <nils@redhat.de>
665 - version 2.0.7
666
667 * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
668 - simplify preun
669
670 * Thu Mar 16 2000 Bill Nottingham <notting@redhat.com>
671 - fix yp_get_default_domain in autoconf
672 - only link against readline for smbclient
673 - fix log rotation (#9909)
674
675 * Fri Feb 25 2000 Bill Nottingham <notting@redhat.com>
676 - fix trigger, again.
677
678 * Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
679 - fix trigger.
680
681 * Fri Feb  4 2000 Bill Nottingham <notting@redhat.com>
682 - turn on quota support
683
684 * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
685 - rebuild to fox dependencies
686 - man pages are compressed
687
688 * Fri Jan 21 2000 Bill Nottingham <notting@redhat.com>
689 - munge post scripts slightly
690
691 * Wed Jan 19 2000 Bill Nottingham <notting@redhat.com>
692 - turn on mmap again. Wheee.
693 - ship smbmount on alpha
694
695 * Mon Dec  6 1999 Bill Nottingham <notting@redhat.com>
696 - turn off mmap. ;)
697
698 * Wed Dec  1 1999 Bill Nottingham <notting@redhat.com>
699 - change /var/log/samba to 0700
700 - turn on mmap support
701
702 * Thu Nov 11 1999 Bill Nottingham <notting@redhat.com>
703 - update to 2.0.6
704
705 * Fri Oct 29 1999 Bill Nottingham <notting@redhat.com>
706 - add a %defattr for -common
707
708 * Tue Oct  5 1999 Bill Nottingham <notting@redhat.com>
709 - shift some files into -client
710 - remove /home/samba from package.
711
712 * Tue Sep 28 1999 Bill Nottingham <notting@redhat.com>
713 - initscript oopsie. killproc <name> -HUP, not other way around.
714
715 * Sat Sep 26 1999 Bill Nottingham <notting@redhat.com>
716 - script cleanups. Again.
717
718 * Wed Sep 22 1999 Bill Nottingham <notting@redhat.com>
719 - add a patch to fix dropped reconnection attempts
720
721 * Mon Sep  6 1999 Jeff Johnson <jbj@redhat.com>
722 - use cp rather than mv to preserve /etc/services perms (#4938 et al).
723 - use mktemp to generate /etc/tmp.XXXXXX file name.
724 - add prereqs on sed/mktemp/killall (need to move killall to /bin).
725 - fix trigger syntax (i.e. "samba < 1.9.18p7" not "samba < samba-1.9.18p7")
726
727 * Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
728 - sed "s|nawk|gawk|" /usr/bin/convert_smbpasswd
729
730 * Sat Aug 21 1999 Bill Nottingham <notting@redhat.com>
731 - fix typo in mount.smb
732
733 * Fri Aug 20 1999 Bill Nottingham <notting@redhat.com>
734 - add a %trigger to work around (sort of) broken scripts in
735   previous releases
736
737 * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
738 - initscript munging
739
740 * Mon Aug  9 1999 Bill Nottingham <notting@redhat.com>
741 - add domain parsing to mount.smb
742
743 * Fri Aug  6 1999 Bill Nottingham <notting@redhat.com>
744 - add a -common package, shuffle files around.
745
746 * Fri Jul 23 1999 Bill Nottingham <notting@redhat.com>
747 - add a chmod in %postun so /etc/services & inetd.conf don't become unreadable
748
749 * Wed Jul 21 1999 Bill Nottingham <notting@redhat.com>
750 - update to 2.0.5
751 - fix mount.smb - smbmount options changed again.........
752 - fix postun. oops.
753 - update some stuff from the samba team's spec file.
754
755 * Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
756 - split off clients into separate package
757 - don't run samba by default
758
759 * Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
760 - fix one problem with mount.smb script
761 - fix smbpasswd on sparc with a really ugly kludge
762
763 * Thu Jun 10 1999 Dale Lovelace <dale@redhat.com>
764 - fixed logrotate script
765
766 * Tue May 25 1999 Bill Nottingham <notting@redhat.com>
767 - turn of 64-bit locking on 32-bit platforms
768
769 * Thu May 20 1999 Bill Nottingham <notting@redhat.com>
770 - so many releases, so little time
771 - explicitly uncomment 'printing = bsd' in sample config
772
773 * Tue May 18 1999 Bill Nottingham <notting@redhat.com>
774 - update to 2.0.4a
775 - fix mount.smb arg ordering
776
777 * Fri Apr 16 1999 Bill Nottingham <notting@redhat.com>
778 - go back to stop/start for restart (-HUP didn't work in testing)
779
780 * Fri Mar 26 1999 Bill Nottingham <notting@redhat.com>
781 - add a mount.smb to make smb mounting a little easier.
782 - smb filesystems apparently don't work on alpha. Oops.
783
784 * Thu Mar 25 1999 Bill Nottingham <notting@redhat.com>
785 - always create codepages
786
787 * Tue Mar 23 1999 Bill Nottingham <notting@redhat.com>
788 - logrotate changes
789
790 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> 
791 - auto rebuild in the new build environment (release 3)
792
793 * Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
794 - updated init script to use graceful restart (not stop/start)
795
796 * Tue Mar  9 1999 Bill Nottingham <notting@redhat.com>
797 - update to 2.0.3
798
799 * Thu Feb 18 1999 Bill Nottingham <notting@redhat.com>
800 - update to 2.0.2
801
802 * Mon Feb 15 1999 Bill Nottingham <notting@redhat.com>
803 - swat swat
804
805 * Tue Feb  9 1999 Bill Nottingham <notting@redhat.com>
806 - fix bash2 breakage in post script
807
808 * Fri Feb  5 1999 Bill Nottingham <notting@redhat.com>
809 - update to 2.0.0
810
811 * Mon Oct 12 1998 Cristian Gafton <gafton@redhat.com>
812 - make sure all binaries are stripped
813
814 * Thu Sep 17 1998 Jeff Johnson <jbj@redhat.com>
815 - update to 1.9.18p10.
816 - fix %triggerpostun.
817
818 * Tue Jul 07 1998 Erik Troan <ewt@redhat.com>
819 - updated postun triggerscript to check $0
820 - clear /etc/codepages from %preun instead of %postun
821
822 * Mon Jun 08 1998 Erik Troan <ewt@redhat.com>
823 - made the %postun script a tad less agressive; no reason to remove
824   the logs or lock file (after all, if the lock file is still there,
825   samba is still running)
826 - the %postun and %preun should only exectute if this is the final
827   removal
828 - migrated %triggerpostun from Red Hat's samba package to work around
829   packaging problems in some Red Hat samba releases
830
831 * Sun Apr 26 1998 John H Terpstra <jht@samba.anu.edu.au>
832 - minor tidy up in preparation for release of 1.9.18p5
833 - added findsmb utility from SGI package
834
835 * Wed Mar 18 1998 John H Terpstra <jht@samba.anu.edu.au>
836 - Updated version and codepage info.
837 - Release to test name resolve order
838
839 * Sat Jan 24 1998 John H Terpstra <jht@samba.anu.edu.au>
840 - Many optimisations (some suggested by Manoj Kasichainula <manojk@io.com>
841 - Use of chkconfig in place of individual symlinks to /etc/rc.d/init/smb
842 - Compounded make line
843 - Updated smb.init restart mechanism
844 - Use compound mkdir -p line instead of individual calls to mkdir
845 - Fixed smb.conf file path for log files
846 - Fixed smb.conf file path for incoming smb print spool directory
847 - Added a number of options to smb.conf file
848 - Added smbadduser command (missed from all previous RPMs) - Doooh!
849 - Added smbuser file and smb.conf file updates for username map
850