macos-update-readme-20040317
[openafs.git] / src / packaging / RedHat / openafs-1.2.6.spec
1 %define afsvers 1.2.6
2 %define pkgrel 1
3
4 # Define your particular Red Hat and kernel versions:
5 #       For Linux 2.2:  22
6 #       For Linux 2.4:  24
7 #
8 %define osvers rh7.1
9 %define kernvers 24
10
11 # This is where to look for kernel-build includes files.
12 # Most likely you don't want to change this, but
13 # depending on your situation you may want:
14 #       Linux 2.2:
15 #               kbase = /usr/src/linux-
16 #               kend = ""
17 #       Linux 2.4:
18 #               kbase = /lib/modules/
19 #               kend = /build
20 #
21 %define kbase /usr/src/linux-
22 %define kend ""
23
24 # Set 'debugspec' to 1 if you want to debug the spec file.  This will
25 # not remove the installed tree as part of the %clean operation
26 %define debugspec 0
27
28 # Set 'enterprisekernelsupport' to 1 if you want to build the
29 # kernel module for the enterprise kernel
30 # Note: This will only work for kernvers == 24 on i686
31 %define enterprisekernelsupport 1
32
33 # Set 'bigmemkernelsupport' to 1 if you want to build the
34 # kernel module for the bigmem kernel
35 # Note: This will only work for kernvers == 24 on i686
36 %define bigmemkernelsupport 1
37
38 # Set 'krb5support' to 1 if you want to build the openafs-krb5 package
39 # to distribute aklog and asetkey
40 %define krb5support 1
41
42 # OpenAFS configuration options
43 %define enable_bitmap_later 0
44 %define enable_bos_restricted_mode 0
45 %define enable_fast_restart 0
46
47 #######################################################################
48 # You probably don't need to change anything beyond this line
49 # NOTE: If you do, please email me!!!
50
51 Summary: OpenAFS distributed filesystem
52 Name: openafs
53 Version: %{afsvers}
54 Release: %{osvers}.%{pkgrel}
55 Copyright: IPL
56 BuildRoot: %{_tmppath}/%{name}-%{version}-root
57 Packager: Derek Atkins <warlord@MIT.EDU>
58 Group: Networking/Filesystems
59 BuildRequires: kernel-source
60 %if "%{osvers}" != "rh6.2"
61 # Newer versions of Red Hat require pam-devel in order to build
62 BuildRequires: pam-devel
63 %endif
64
65 Source0: http://www.openafs.org/dl/openafs/${afsvers}/openafs-%{afsvers}-src.tar.gz
66 Source1: http://www.openafs.org/dl/openafs/${afsvers}/openafs-%{afsvers}-doc.tar.gz
67 Source2: openafs-ThisCell
68 # http://grand.central.org/dl/cellservdb/CellServDB
69 Source3: openafs-CellServDB
70 Source4: openafs-SuidCells
71 Source5: openafs-cacheinfo
72 Source6: openafs-afsmodname
73 Source7: openafs-LICENSE.Sun
74 Source8: openafs-README
75 Source10: http://www.openafs.org/dl/openafs/${afsvers}/RELNOTES-%{afsvers}
76 Source11: http://www.openafs.org/dl/openafs/${afsvers}/ChangeLog
77
78 Source20: openafs-krb5-1.3.tar.gz
79
80 Patch0: openafs-%{afsvers}-rc.patch
81
82 Patch20: openafs-krb5-1.3-1.2.1.diff.gz
83 Patch21: openafs-krb5-1.3-configure.patch
84
85 %description
86 The AFS distributed filesystem.  AFS is a distributed filesystem
87 allowing cross-platform sharing of files among multiple computers.
88 Facilities are provided for access control, authentication, backup and
89 administrative management.
90
91 This package provides common files shared across all the various
92 OpenAFS packages but are not necessarily tied to a client or server.
93
94 %package client
95 Requires: binutils, openafs-kernel, openafs = %{PACKAGE_VERSION}
96 Summary: OpenAFS Filesystem Client
97 Group: Networking/Filesystem
98
99 %description client
100 The AFS distributed filesystem.  AFS is a distributed filesystem
101 allowing cross-platform sharing of files among multiple computers.
102 Facilities are provided for access control, authentication, backup and
103 administrative management.
104
105 This package provides basic client support to mount and manipulate
106 AFS.
107
108 %package server
109 Requires: openafs-kernel, openafs = %{PACKAGE_VERSION}
110 Summary: OpenAFS Filesystem Server
111 Group: Networking/Filesystems
112
113 %description server
114 The AFS distributed filesystem.  AFS is a distributed filesystem
115 allowing cross-platform sharing of files among multiple computers.
116 Facilities are provided for access control, authentication, backup and
117 administrative management.
118
119 This package provides basic server support to host files in an AFS
120 Cell.
121
122 %package devel
123 Summary: OpenAFS Development Libraries and Headers
124 Group: Development/Filesystems
125
126 %description devel
127 The AFS distributed filesystem.  AFS is a distributed filesystem
128 allowing cross-platform sharing of files among multiple computers.
129 Facilities are provided for access control, authentication, backup and
130 administrative management.
131
132 This package provides static development libraries and headers needed
133 to compile AFS applications.  Note: AFS currently does not provide
134 shared libraries.
135
136 %package kernel
137 Summary: OpenAFS Kernel Module(s)
138 Requires: openafs = %{PACKAGE_VERSION}
139 Group: Networking/Filesystems
140
141 %description kernel
142 The AFS distributed filesystem.  AFS is a distributed filesystem
143 allowing cross-platform sharing of files among multiple computers.
144 Facilities are provided for access control, authentication, backup and
145 administrative management.
146
147 This package provides precompiled AFS kernel modules for various
148 kernels.
149
150 %package kernel-source
151 Summary: OpenAFS Kernel Module source tree
152 Group: Networking/Filesystems
153
154 %description kernel-source
155 The AFS distributed filesystem.  AFS is a distributed filesystem
156 allowing cross-platform sharing of files among multiple computers.
157 Facilities are provided for access control, authentication, backup and
158 administrative management.
159
160 This package provides the source code to build your own AFS kernel
161 module.
162
163 %package compat
164 Summary: OpenAFS client compatibility symlinks
165 Requires: openafs = %{PACKAGE_VERSION}, openafs-client = %{PACKAGE_VERSION}
166 Group: Networking/Filesystems
167 Obsoletes: openafs-client-compat
168
169 %description compat
170 The AFS distributed filesystem.  AFS is a distributed filesystem
171 allowing cross-platform sharing of files among multiple computers.
172 Facilities are provided for access control, authentication, backup and
173 administrative management.
174
175 This package provides compatibility symlinks in /usr/afsws.  It is
176 completely optional, and is only necessary to support legacy
177 applications and scripts that hard-code the location of AFS client
178 programs.
179
180 %package kpasswd
181 Summary: OpenAFS KA kpasswd support
182 Requires: openafs
183 Group: Networking/Filesystems
184
185 %description kpasswd
186 The AFS distributed filesystem.  AFS is a distributed filesystem
187 allowing cross-platform sharing of files among multiple computers.
188 Facilities are provided for access control, authentication, backup and
189 administrative management.
190
191 This package provides the compatibility symlink for kpasswd, in case
192 you are using KAserver instead of Krb5.
193
194 %if %{krb5support}
195 %package krb5
196 Summary: OpenAFS programs to use with krb5
197 Requires: openafs = %{PACKAGE_VERSION}
198 Group: Networking/Filesystems
199 BuildRequires: krb5-devel
200
201 %description krb5
202 The AFS distributed filesystem.  AFS is a distributed filesystem
203 allowing cross-platform sharing of files among multiple computers.
204 Facilities are provided for access control, authentication, backup and
205 administrative management.
206
207 This package provides compatibility programs so you can use krb5
208 to authenticate to AFS services, instead of using AFS's homegrown
209 krb4 lookalike services.
210 %endif
211
212 #
213 # PREP
214 #
215
216 %prep
217 %setup -q -b 1
218 %setup -q -T -D -a 20
219
220 %patch0 -p0
221 %patch20 -p0
222 %patch21 -p0
223
224 ###
225 ### build
226 ###
227 %build
228
229 %ifarch i386 i486 i586 i686 athlon
230 sysbase=i386
231 sysname=${sysbase}_linux%{kernvers}
232 %else
233 sysbase=%{_arch}
234 sysname=${sysbase}_linux%{kernvers}
235 %endif
236
237 if [ %{kernvers} = 22 ]; then
238    kv='2\.2\.'
239 elif [ %{kernvers} = 24 ]; then
240    kv='2\.4\.'
241 else
242    echo "I don't know how to build $sysname"
243    exit 1
244 fi
245
246 %ifarch i386 i486 i586 i686 athlon
247 archlist="i386 i586 i686 athlon"
248 %else
249 archlist=${sysbase}
250 %endif
251
252 #
253 # PrintDefine var value statements file
254 #
255 PrintDefine() {
256     case $3 in
257     *ifn*)
258         echo "#ifndef $1" >> $4
259         ;;
260     esac
261     case $3 in
262     *und*)
263         echo "#undef $1" >> $4
264         ;;
265     esac
266     case $3 in
267     *def*)
268         echo "#define $1 $2" >> $4
269         ;;
270     esac
271     case $3 in
272     *end*)
273         echo "#endif" >> $4
274         ;;
275     esac
276     case $3 in
277     *inc*)
278         echo "#include $1" >> $4
279         ;;
280     esac
281
282
283     case $3 in
284     *nl*)
285         echo "" >> $4
286         ;;
287     esac
288 }
289
290 # PrintRedhatKernelFix arch mp file
291 PrintRedhatKernelFix() {
292     arch="$1"
293     up=0
294     smp=0
295     ent=0
296     bm=0
297     if [ "$2" = "MP" ]; then
298         smp=1
299     elif [ "$2" = "EP" ]; then
300         ent=1
301     elif [ "$2" = "BM" ]; then
302         bm=1
303     else
304         up=1
305     fi
306     file="$3"
307
308     # deal with the various boot kernels
309     boot=0
310     bootsmp=0
311
312     # arch of 'BOOT' == 386
313     if [ "$arch" = "BOOT" ]; then
314         if [ "$up" = 1 ]; then
315             boot=1
316             up=0
317         elif [ "$smp" = 1 ]; then
318             bootsmp=1
319             smp=0
320         fi
321         arch=i386
322     fi
323
324     rm -f $file
325     touch $file
326
327     PrintDefine "REDHAT_FIX_H" "" ifn,def,nl $file
328
329     PrintDefine "__BOOT_KERNEL_ENTERPRISE" $ent und,def,nl $file
330     PrintDefine "__BOOT_KERNEL_BIGMEM" $bm und,def,nl $file
331     PrintDefine "__BOOT_KERNEL_SMP" $smp und,def,nl $file
332     PrintDefine "__BOOT_KERNEL_UP" $up und,def,nl $file
333     PrintDefine "__BOOT_KERNEL_BOOT" $boot und,def,nl $file
334     PrintDefine "__BOOT_KERNEL_BOOTSMP" $bootsmp und,def,nl $file
335
336     PrintDefine \"/boot/kernel.h\" "" inc,nl $file      # include file
337
338     for ar in $archlist ; do
339         if [ "$ar" = "$arch" ]; then
340             PrintDefine "__MODULE_KERNEL_$ar" "1" ifn,def,end $file
341         else
342             PrintDefine "__MODULE_KERNEL_$ar" "" und $file      # undef
343         fi
344     done
345     echo "" >> $file
346
347     PrintDefine "" "" end $file
348
349     if [ %{debugspec} = 1 ] ; then
350         echo "Kernel Configuration File for Red Hat kernels:"
351         cat $file
352     fi
353 }
354
355 # Pick up all the 'appropriate' kernels
356 kvers=`ls -d %{kbase}* | sed 's^%{kbase}^^g' | grep $kv`
357
358 # Choose the last one for now.. It doesn't really matter, really.
359 hdrdir=`ls -d %{kbase}*%{kend} | grep $kv | tail -1`
360
361 config_opts="--enable-redhat-buildsys \
362 %if %{enable_bitmap_later}
363         --enable-bitmap-later \
364 %endif
365 %if %{enable_bos_restricted_mode}
366         --enable-bos-restricted-mode \
367 %endif
368 %if %{enable_fast_restart}
369         --enable-fast-restart \
370 %endif
371         --enable-transarc-paths"
372
373 # Configure AFS
374 ./configure --with-afs-sysname=${sysname} \
375         --with-linux-kernel-headers=$hdrdir $config_opts
376
377 # Build the user-space AFS stuff
378 make dest_nolibafs
379
380 # Build the libafs tree
381 make only_libafs_tree
382
383 # Now build all the kernel modules
384 for vers in $kvers ; do
385
386   # Reconfigure sources for this kernel version, to catch various
387   # kernel params in the configure script.  Yes. this takes more time,
388   # but it's worth it in the long run..  But first remove config.cache
389   # to be sure we get a clean configuration.
390   rm -f config.cache
391   ./configure --with-afs-sysname=${sysname} \
392         --with-linux-kernel-headers=%{kbase}$vers%{kend} \
393         $config_opts
394
395   KTL="SP MP"
396 %if %{enterprisekernelsupport}
397   # See if we should build EP support
398   if grep -q -r __BOOT_KERNEL_ENTERPRISE %{kbase}$vers%{kend}/include
399   then
400     KTL="${KTL} EP"
401   fi
402 %endif
403 %if %{bigmemkernelsupport}
404   # See if we should build BM support
405   if grep -q -r __BOOT_KERNEL_BIGMEM %{kbase}$vers%{kend}/include
406   then
407     KTL="${KTL} BM"
408   fi
409 %endif
410  
411   for mp in $KTL; do
412     # ... for all appropriate 'architectures'...
413     if [ %{kernvers} = 22 ]; then
414         # For 2.2 kernels, just do MP and SP kernels; force EP into i686
415
416         arch=${sysbase}
417         if [ $mp = EP -a ${sysbase} = i386 ]; then
418             arch=i686
419         fi
420
421         PrintRedhatKernelFix $arch $mp src/config/redhat-fix.h
422         make dest_only_libafs LOCAL_SMP_DEF=-DREDHAT_FIX MPS=$mp
423
424     elif [ %{kernvers} = 24 ]; then
425         # For 2.4 kernels, need to build modules for each architecture!
426
427         for arch in $archlist ; do
428
429             # build SP and MP on all architectures.
430             # build EP and BM only on i686
431             if [ $mp = SP -o $mp = MP -o \
432                  \( $mp = EP -a $arch = i686 \) -o \
433                  \( $mp = BM -a $arch = i686 \) ]; then
434                 PrintRedhatKernelFix $arch $mp src/config/redhat-fix.h
435                 make dest_only_libafs LOCAL_SMP_DEF=-DREDHAT_FIX \
436                     LINUX_MODULE_NAME="-$arch" MPS=$mp
437             fi
438         done
439
440     else            
441         echo "I don't know how to build $sysname"
442         exit 1
443     fi
444   done
445 done
446
447 rm -f src/config/redhat-fix.h
448
449 %if %{krb5support}
450 # Now build aklog/asetkey
451 (cd openafs-krb5-1.3/src &&
452         autoconf &&
453         ./configure --prefix=/usr --with-krb5=/usr/kerberos \
454                 --with-afs=`pwd`/../../${sysname}/dest/ && \
455         make all && \
456         make install DESTDIR=`pwd`/../../${sysname}/dest/ INSTALL_BIN=/bin \
457                 INSTALL_SBIN=/etc)
458 %endif
459
460 ###
461 ### install
462 ###
463 %install
464 [ $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
465
466 %ifarch i386 i486 i586 i686 athlon
467 sysbase=i386
468 sysname=${sysbase}_linux%{kernvers}
469 %else
470 sysbase=%{_arch}
471 sysname=${sysbase}_linux%{kernvers}
472 %endif
473
474 # Build install tree
475 mkdir -p $RPM_BUILD_ROOT/usr/sbin
476 mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
477 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
478 mkdir -p $RPM_BUILD_ROOT/etc/openafs
479 mkdir -p $RPM_BUILD_ROOT/lib/security
480 mkdir -p $RPM_BUILD_ROOT/usr/afs/logs
481 mkdir -p $RPM_BUILD_ROOT/usr/vice/etc
482 mkdir -p $RPM_BUILD_ROOT/usr/vice/cache
483 chmod 700 $RPM_BUILD_ROOT/usr/vice/cache
484
485 # Copy files from dest to the appropriate places in BuildRoot
486 tar cf - -C ${sysname}/dest bin include lib | tar xf - -C $RPM_BUILD_ROOT/usr
487 tar cf - -C ${sysname}/dest/etc . | tar xf - -C $RPM_BUILD_ROOT/usr/sbin
488 tar cf - -C ${sysname}/dest/root.server/usr/afs bin | tar xf - -C $RPM_BUILD_ROOT/usr/afs
489 tar cf - -C ${sysname}/dest/root.client/usr/vice/etc afsd modload | tar xf - -C $RPM_BUILD_ROOT/usr/vice/etc
490
491 # Link kpasswd to kapasswd
492 ln -f $RPM_BUILD_ROOT/usr/bin/kpasswd $RPM_BUILD_ROOT/usr/bin/kapasswd
493
494 # Copy root.client config files
495 install -m 755 ${sysname}/dest/root.client/usr/vice/etc/afs.conf $RPM_BUILD_ROOT/etc/sysconfig/afs
496 install -m 755 ${sysname}/dest/root.client/usr/vice/etc/afs.rc $RPM_BUILD_ROOT/etc/rc.d/init.d/afs
497
498 # Copy PAM modules
499 install -m 755 ${sysname}/dest/lib/pam* $RPM_BUILD_ROOT/lib/security
500
501 # PAM symlinks
502 ln -sf pam_afs.so.1 $RPM_BUILD_ROOT/lib/security/pam_afs.so
503 ln -sf pam_afs.krb.so.1 $RPM_BUILD_ROOT/lib/security/pam_afs.krb.so
504
505 # Populate /usr/vice/etc
506 uve=$RPM_BUILD_ROOT/usr/vice/etc
507 install -p -m 644 $RPM_SOURCE_DIR/openafs-CellServDB $uve/CellServDB
508 install -p -m 644 $RPM_SOURCE_DIR/openafs-SuidCells $uve/SuidCells
509 install -p -m 644 $RPM_SOURCE_DIR/openafs-ThisCell $uve/ThisCell
510 install -p -m 644 $RPM_SOURCE_DIR/openafs-cacheinfo $uve/cacheinfo
511 install -p -m 755 $RPM_SOURCE_DIR/openafs-afsmodname $uve/afsmodname
512
513 #
514 # Build the SymTable
515 symtable=$RPM_BUILD_ROOT/usr/vice/etc/modload/SymTable
516 rm -f $symtable
517 echo "# SymTable, automatically generated" > $symtable
518 echo "# symbol  version cpu     module" >> $symtable
519 echo "" >> $symtable
520
521 $RPM_BUILD_ROOT/usr/vice/etc/afsmodname -x -f $symtable \
522         $RPM_BUILD_ROOT/usr/vice/etc/modload/libafs*.o
523
524 #
525 # install kernel-source
526 #
527
528 # Install the kernel module source tree
529 mkdir -p $RPM_BUILD_ROOT/usr/src/openafs-kernel-%{afsvers}/src
530 tar cf - -C libafs_tree . | \
531         tar xf - -C $RPM_BUILD_ROOT/usr/src/openafs-kernel-%{afsvers}/src
532
533 # Next, copy the LICENSE Files, README
534 install -m 644 src/LICENSE $RPM_BUILD_ROOT/usr/src/openafs-kernel-%{afsvers}/LICENSE.IBM
535 install -m 644 $RPM_SOURCE_DIR/openafs-LICENSE.Sun $RPM_BUILD_ROOT/usr/src/openafs-kernel-%{afsvers}/LICENSE.Sun
536 install -m 644 $RPM_SOURCE_DIR/openafs-README $RPM_BUILD_ROOT/usr/src/openafs-kernel-%{afsvers}/README
537
538 #
539 # Install DOCUMENTATION
540 #
541
542 # Build the DOC directory
543 mkdir -p $RPM_BUILD_ROOT/$RPM_DOC_DIR/openafs-%{afsvers}
544 tar cf - -C doc LICENSE html pdf | \
545     tar xf - -C $RPM_BUILD_ROOT/$RPM_DOC_DIR/openafs-%{afsvers}
546 install -m 644 $RPM_SOURCE_DIR/RELNOTES-%{afsvers} $RPM_BUILD_ROOT/$RPM_DOC_DIR/openafs-%{afsvers}
547 install -m 644 $RPM_SOURCE_DIR/ChangeLog $RPM_BUILD_ROOT/$RPM_DOC_DIR/openafs-%{afsvers}
548
549 #
550 # create filelist
551 #
552 grep -v "^#" >openafs-file-list <<EOF-openafs-file-list
553 /usr/bin/afsmonitor
554 /usr/bin/bos
555 /usr/bin/fs
556 /usr/bin/kapasswd
557 /usr/bin/kpasswd
558 /usr/bin/klog
559 /usr/bin/klog.krb
560 /usr/bin/pagsh
561 /usr/bin/pagsh.krb
562 /usr/bin/pts
563 /usr/bin/scout
564 /usr/bin/sys
565 /usr/bin/tokens
566 /usr/bin/tokens.krb
567 /usr/bin/translate_et
568 /usr/bin/udebug
569 /usr/bin/unlog
570 /usr/sbin/backup
571 /usr/sbin/butc
572 /usr/sbin/fms
573 /usr/sbin/fstrace
574 /usr/sbin/kas
575 /usr/sbin/read_tape
576 /usr/sbin/restorevol
577 /usr/sbin/rxdebug
578 /usr/sbin/uss
579 /usr/sbin/vos
580 EOF-openafs-file-list
581
582 #
583 # Install compatiblity links
584 #
585 for d in bin:bin etc:sbin; do
586   olddir=`echo $d | sed 's/:.*$//'`
587   newdir=`echo $d | sed 's/^.*://'`
588   mkdir -p $RPM_BUILD_ROOT/usr/afsws/$olddir
589   for f in `cat openafs-file-list`; do
590     if echo $f | grep -q /$newdir/; then
591       fb=`basename $f`
592       ln -sf /usr/$newdir/$fb $RPM_BUILD_ROOT/usr/afsws/$olddir/$fb
593     fi
594   done
595 done
596
597
598 ###
599 ### clean
600 ###
601 %clean
602 rm -f openafs-file-list
603 [ "$RPM_BUILD_ROOT" != "/" -a "x%{debugspec}" != "x1" ] && \
604         rm -fr $RPM_BUILD_ROOT
605
606
607 ###
608 ### scripts
609 ###
610 %pre compat
611 if [ -e /usr/afsws ]; then
612         /bin/rm -fr /usr/afsws
613 fi
614
615 %post
616 chkconfig --add afs
617
618 %post client
619 if [ ! -d /afs ]; then
620         mkdir /afs
621         chown root.root /afs
622         chmod 0755 /afs
623 fi
624
625 echo
626 echo The AFS cache is configured for 100 MB. Edit the 
627 echo /usr/vice/etc/cacheinfo file to change this before
628 echo running AFS for the first time. You should also
629 echo set your home cell in /usr/vice/etc/ThisCell.
630 echo
631 echo Also, you may want to edit /etc/pam.d/login and 
632 echo possibly others there to get an AFS token on login.
633 echo Put the line:
634 echo 
635 echo    auth       sufficient   /lib/security/pam_afs.so try_first_pass ignore_root
636 echo
637 echo before the one for pwdb.
638 echo
639
640 %post server
641 if [ -f /etc/sysconfig/afs ] ; then
642         srv=`grep ^AFS_SERVER /etc/sysconfig/afs | sed 's/^AFS_SERVER[\s]*=[\s]*//'`
643         if [ "x$srv" = "xon" ] ; then
644                 exit 0
645         fi
646 fi
647
648 echo
649 echo Be sure to edit /etc/sysconfig/afs and turn AFS_SERVER on
650 echo
651
652 %preun
653 if [ $1 = 0 ] ; then
654         /etc/rc.d/init.d/afs stop
655         chkconfig --del afs
656         [ -d /afs ] && rmdir /afs
657 fi
658
659 ###
660 ### file lists
661 ###
662 %files -f openafs-file-list
663 %defattr(-,root,root)
664 %config /etc/sysconfig/afs
665 %doc %{_docdir}/openafs-%{afsvers}
666 /etc/rc.d/init.d/afs
667
668 %files client
669 %defattr(-,root,root)
670 %dir /usr/vice
671 %dir /usr/vice/cache
672 %dir /usr/vice/etc
673 %dir /usr/vice/etc/modload
674 %config /usr/vice/etc/CellServDB
675 %config /usr/vice/etc/SuidCells
676 %config /usr/vice/etc/ThisCell
677 %config /usr/vice/etc/cacheinfo
678 /usr/bin/cmdebug
679 /usr/bin/up
680 /usr/vice/etc/afsd
681 /usr/vice/etc/afsmodname
682 /lib/security/pam_afs.krb.so.1
683 /lib/security/pam_afs.krb.so
684 /lib/security/pam_afs.so.1
685 /lib/security/pam_afs.so
686
687 %files server
688 %defattr(-,root,root)
689 %dir /usr/afs
690 %dir /usr/afs/bin
691 %dir /usr/afs/logs
692 /usr/afs/bin/bosserver
693 /usr/afs/bin/buserver
694 /usr/afs/bin/fileserver
695 # Should we support KAServer?
696 /usr/afs/bin/kaserver
697 /usr/afs/bin/kpwvalid
698 /usr/afs/bin/pt_util
699 /usr/afs/bin/ptserver
700 /usr/afs/bin/salvager
701 /usr/afs/bin/upclient
702 /usr/afs/bin/upserver
703 /usr/afs/bin/vlserver
704 /usr/afs/bin/volinfo
705 /usr/afs/bin/volserver
706 /usr/sbin/prdb_check
707 /usr/sbin/vldb_check
708 /usr/sbin/vldb_convert
709
710 %files devel
711 %defattr(-,root,root)
712 /usr/bin/rxgen
713 /usr/include/afs
714 /usr/include/des.h
715 /usr/include/des_conf.h
716 /usr/include/des_odd.h
717 /usr/include/lock.h
718 /usr/include/lwp.h
719 /usr/include/mit-cpyright.h
720 /usr/include/potpourri.h
721 /usr/include/preempt.h
722 /usr/include/rx
723 /usr/include/timer.h
724 /usr/include/ubik.h
725 /usr/include/ubik_int.h
726 /usr/lib/afs
727 /usr/lib/libafsauthent.a
728 /usr/lib/libafsrpc.a
729 /usr/lib/libdes.a
730 /usr/lib/liblwp.a
731 /usr/lib/librx.a
732 /usr/lib/librxkad.a
733 /usr/lib/librxstat.a
734 /usr/lib/libubik.a
735
736 %files kernel
737 %defattr(-,root,root)
738 /usr/vice/etc/modload/libafs*.o
739 /usr/vice/etc/modload/SymTable
740
741 %files kernel-source
742 %defattr(-,root,root)
743 /usr/src/openafs-kernel-%{afsvers}/LICENSE.IBM
744 /usr/src/openafs-kernel-%{afsvers}/LICENSE.Sun
745 /usr/src/openafs-kernel-%{afsvers}/README
746 /usr/src/openafs-kernel-%{afsvers}/src
747
748 %files compat
749 %defattr(-,root,root)
750 /usr/afsws
751
752 %files kpasswd
753 %defattr(-,root,root)
754 /usr/bin/kpasswd
755 /usr/bin/kpwvalid
756
757 %if %{krb5support}
758 %files krb5
759 %defattr(-,root,root)
760 /usr/bin/aklog
761 /usr/sbin/asetkey
762 %endif